Welcome, Guest! Login | Register
even on contact/counter bug?
Info
Report
44 Posts

i decided to make this its own thread in hope that more people will read this since its something i addressed in the thread of my game, if its agains the rules im sorry

i have a counter that activates whenever my 1st person camera and a car have contact, but for some reason more often that not when it happens the counter gets activated twice, even if in the EOC i also put two event on times to prevent multiple collisions in a 1 second timespan to happen

it's very inconsistent and i dont know where the problem lies

EDIT: it isnt limited to cars alone, so MAYBE its a 1st person camera problem, since i dont think ive noticed any problems with the counter linked to the EOC that lowers the enemy bar

RE-EDIT: forget that the enemy health is also afflicted by this problem, so the problem comes no doubt from the EOC or the counter
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
246 Posts

I suspect everything is fine and working properly.

Image anything hitting something else, there no guarantee a bounce effect wont happen, even if its small.

I think what you need to do is setup a timer delay on contact too, that prevents a second hit from counting, for say 0.5 seconds.

Or, you'll need to apply another preventive measure, like disable iObjectHide() the rigidbody for a half second ( i assume the rigidbody has a skinmesh which you could leave visible.

I don't see an issue here with the collision, but more with what you're expecting to happen, isn't as simple as you want it to be, so you'll need to setup some process to deal with it. @buska
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
44 Posts

@tinsoldier

i may have explained myself badly but the timer delay is what i mentioned in my original post

i am thinking it could be more related with the timers not acting in time to prevent a second collision from happening, wheter or not its by stopping the EOC or the collisions themselves
Created on: 1 week ago
Info
Report
246 Posts

I still think you need to look at the problem differently...

PS the project needs a gun-site sprite, to help with long distance targeting .

EDIT:  Share the project if you like and let someone else check into the issue ? @buska
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
44 Posts

@tinsoldier maybe you're right, but as of now i dont have any ideas

https://drive.google.com/file/d/1VehC2kIGUDozJcf6GlgYgpw4_qW8xXTO/view?usp=sharing

btw in case anyone can help here's the exoskeleton of my projects, its a bit outdated and messy looking but the bug is there
Created on: 1 week ago
Info
Report
246 Posts

@buska
So i checked all your project objects, i found two valueprint objects that were corrupt and crashed 3drad when i tried to open their properties , i replaced them both.

This tells me your 3drad install is corrupt or maybe just the valueprint objects... so i would highly suggest you re-install 3drad...

Just run the install program again, it should select the current install location, and it's recommended to install over top of your current install, you wont loose any project history or projects, except the original included projects, which would be refreshed .

This process may just fix your problem, or you may have too replace any current valueprints in your project, they may be corrupt now too.. to find out, just open each objects properties, and check to be sure its required resource are there, be it a sprite or rigidbody or what ever.

If all the objects seem ok and the project doesn't crash after the 3drad reinstall, let me know and i'll check the project for other issues.
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
44 Posts

@tinsoldier yours was a good advice since now 3d rads camera doesnt flicker like hell anymore when i try to move an object now that i reinstalled

problem is, i replaced counter, valueprint and eoc, but the bug still is there

just to be sure, by opening the objects propreties you mean doubleclicking on the grey column on the right, correct?
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
246 Posts

@buska, no.. it's on the left, but what ever way you open them, yes, also check the resource to be sure it's there too, 3drad will crash if a resource has been removed and the object properties not updated.

But anyway i look into the project closer ..

EDIT @buska  I don't think i can testout your project.. i've found a few other problems as well, loke rightclicking a rigidbody is also crashing 3drad... there a number of issues going on, you should delete this project you shared with me due to corrupt resources in it.  

That being said, what about your current version.. are all the objects properties working.. and behaving properly..

The big issue here is 3drad is faulty by it's self, i've seen small simple projects get Fu*ked up for no reason.

I've seen 3drad change element property values, and the project wasn't even run yet, the editing process was doing it.

I've seen and screen captured a skinmesh properties where the 6 object rotation & location values had 4 blank ( not even zeros) and 2 had random text where numbers should be.

I suspect most people have errors and or bugs show up in their projects and don't even know it..
the issue here is 3drad wont abort a run when it encounters an error, for instance in a script file, it instead disables that script and continues to run the project.

The other problem here is 3drads error reporting system is broken, if you ever actually see an error box popup, you'll only see that 1 time, from then on you have to exit 3drad and "maybe" even reboot your computer to get the error system to partially work again, but still only ever 1 error box will show up even if you had 40 of them.... it sucks.. but what do you do..

There were erroes reported to Fernando while he was still actively developing 3drad, but instead of fixing them, he replay was " he uses a `clean` system to develop on... but didn't bother to explain exactly what that meant, and what about the end compiled project.. does this mean the user would also need a `clean` system to use our projects ??  

3drad has problems, they will never be fixed...

Your just gonna have to wait to 3dradspace comes out...
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
44 Posts

@tinsoldier

its weird that you're reporting  me all of these issues you're having since aside from the valueprint doubling itself i have had exactly no problems with that i was working on, wether its on the game itself or on the 3d rad editor, out of curiosity, which version are you using? i have donwloaded the 7.22 version myself

but to be fair 3drad did cause me some very dumb problems in the past that i couldnt wrap my head around no matter the version, its a really janky software regardless and im sure i could mention even more bugs other than the ones you just said
Created on: 1 week ago
Edited on: 1 week ago
Info
Report
246 Posts

yeah v7.22

FYI  v5.2 developed by Leonardo is stable, i know of only 1 issue and it effects only the last 512th element, if that element has collisions defined, collisions wont work.

i'm un awear of any other issues, and i've been using 3drad since v4.1

Opps almost forgot about about 3drad v5.2's visual collision editor, while NOT a bug, but design flaw, if you have 512 elements in your level, the collision editor scales to fit all 512 elements on one screen, and because v5.2's maximum screen res is 1024x768 .. image a box on screen only  2 pixels wide and to set a collision you need to mouse click on it ..........  

The good news is, i made a custom collision editor in 3drad itself that used pages so no more cramping everything together.

Buuut don't ask for that project, i haven't used v5.2 in years, maybe 9 or 10.. i forget now, but its been a while.
Created on: 1 week ago
Edited on: 1 week ago
Reply
Preview
Post
Or use the advanced reply form here...
Sponsored